
Lesson 0: 

This lesson demonstrates most of the basic features of DigiElch such as running a simulation, copying & pasting 

simulation objects, saving and exporting of simulation data, customizing colors and screen display, zooming the 

screen display, retrieving the coordinates of individual current points etc. For this purpose we are going to 

simulate a cyclic voltammogram (CV) for a simple charge-transfer mechanism that refers to a CV-experiment 

measured in the potential range between 0 and -1V at a mercury drop electrode with a scan rate of 10 V/s. The 

size of the mercury drop corresponds to a mercury mass of 4 mg. In the next step it is investigated how the shape 

of the current curve changes if first- and second-order chemical reactions are coupled with the charge-transfer 

process in the form of follow-up reactions.   

 

When working through the lesson, please, keep in mind that some menu commands may be disabled as long as 

DigiElch is running as trial installation.    
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1. Running a cyclic voltammetric simulation 

1.1. Starting the program and selecting the document type for running cyclic voltammetric simulations  

Start DigiElch, click on File -> New ( ) and select 

CV-Simulation Document in the appearing dialog-box 

 

 

 

1.2. Defining a simple charge transfer mechanism 

Click on Simulation -> Edit Properties ( ) and make sure that the Chemical Reactions page is activated. For 

entering the charge-transfer reaction, click on the left-most index field associated with the first empty line in 

Charge-Transfer Reaction. The index field will be transformed into a combo box offering the options shown in 

following picture 

Select Add new Reaction and complete the appearing charge-transfer reaction template  
 

Meaning: 
Ox: Name of the species representing the oxidized form 

Red: Name of the species representing the reduced form 

Reaction Types: 

Ox + e- = Red    

(kf and kb computed from Butler-Volmer or Marcus equation ) 

Ox + ne- = Red   (n=2, 3,4,…, 9) 
(kf and kb computed from Butler-Volmer equation) 

Ox + e- => Red    

(kf  computed from Butler-Volmer or Marcus equation, kb = 0 ) 

Ox + ne- => Red   (n=2, 3,4,…, 9) 

(kf  computed from Butler-Volmer equation, kb=0) 
(kf and kb computed from Butler-Volmer equation) 

Ox + e- <= Red    

(kb computed from Butler-Volmer or Marcus equation, kf = 0 ) 

Ox + ne- <= Red   (n=2, 3,4,…, 9) 

(kb  computed from Butler-Volmer equation, kf=0 

 

 

 

 



Remarks  

 Whether the Butler-Volmer – or Marcus- equation is used for computing kf and kb depends on whether the α –button or the λ (eV)-
button is activated in Charge-Transfer Reaction: 

 Butler-Volmer kinetics                    Marcus-kinetic 
The selection applies to all charge-transfer reactions. It cannot be adjusted individually for each reaction.  

 Marcus-kinetics is allowed only for charge-transfer reactions with n=1. All charge-transfer reactions are reset to Butler-Volmer –
kinetics when adding a reaction with n>1. 

 Charge transfer reactions must always be formulated to proceed as a reduction from the left to the right. Whether a charge transfer 
step does really proceed as reduction or oxidation is determined by the relation between initial and standard potential and the 

direction of the potential scan. 
 The species name of oxidized and reduced form must not be equal or empty. 

 Any character (including space) can be used in a species name but the first character must not be X, Y or Z. 

For the purposes of the actual example it is most convenient to stay with the default species names and to select a 

single (quasi-reversible) charge-transfer step ( “+ e =”) in combination with Butler-Volmer kinetics so that E°, α 

and ks have the usual meaning of standard potential, charge-transfer coefficient and heterogeneous standard 

rate constant. Close the charge-transfer reaction template with OK and enter the following values for E°, α and 

ks 

Complete the Chemical Reactions page by entering analytical concentrations for all involved species as shown in 

the following picture 

 

1.3. Defining the simulation parameters 

Activate the Simulation Parameters page. Modify the potential scan, select the electrode geometry spherical 

(Hg) and enter a mercury mass of 4 mg as shown in the following pictures 

 

 

Do not modify the remaining parameters close the CV-Properties dialog by clicking on OK. 

 

  



1.4. Running the simulation using the Fixed Grid Simulator 

Click on Simulation -> Run -> Fixed Grid Simulation ( ). The picture on the left-hand side shows the current 

curve that should appear as soon as the simulation has terminated 

 

 

 
 

 

 

 

 

 

The picture on the right-hand side shows a summary of the simulation stats obtained when clicking on the 

Simulation -> Stats command: 

 CPU-Time(s):   depends on the CPU-power of the computer; 0 is retrieved if the simulation takes less than one millisecond.  

 Simulation method:  indicates whether the Fixed Grid Simulator or the Adaptive Grid Simulator was used for simulating the CV 

 Boxes perpendicular to electrode:  in the actual case 16 boxes (grid points) were used for simulating the concentration profile in 

x-direction (perpendicular to the electrode surface) 

 Boxes parallel to electrode:  a value is shown only for a two-dimensional simulation where the number represents the boxes (grid 

points) used for simulating the concentration profile in y-direction (parallel to the electrode surface) 

 Relative Flux Error effected by time discretisation:  a number is shown only for simulations executed with the Fixed Grid 

Simulator (box method). For this method it is relatively easy and straightforward to compute an accurate estimate for the relative 

flux error (resulting from the finite size of the potential steps) at run time.     

 

1.5. Running the simulation using the Adaptive Grid Simulator 

Alternatively the simulation can be executed with an Adaptive Grid Simulator based on the finite element 

method (FEM). In this case the simulation starts with the same number and distribution of grid points as used by 

the Fixed Grid Simulator but additional grid points may be introduced after each time/potential step in order to 

ensure that the error level in the simulated concentration profiles remains smaller than a predefined value. This 

Local FEM Error-value can be defined on the Simulation Parameters page:  

 

The smaller this value, the more grid points will be used for simulating the 

concentration profile, the more accurate is the simulated flux, and the longer 

takes the computation. However, the grid refinement is switched off if Local 

FEM Error = 0. In that case the simulation is executed using the FEM 

simulator on a fixed expanding grid identical with that used by the box method (“Fixed Grid Simulator”). 

 

Note that the FEM-simulator is second-order accurate for simulating both flux and concentration profiles while 

the box method is the only method that attains exponential convergence for the simulated flux error. For this 

reason a significantly higher number of grid points (and significantly higher computational costs) are required by 

the Adaptive Grid Simulator to achieve a flux-accuracy comparable to that obtained with the box method even 

when using the latter method on strongly expanding grids.  Because of the higher efficiency, the use of the Fixed 

Grid Simulator is recommended by default.  

 

For demonstrating the higher efficiency of the Fixed Grid Simulator we are going to compare the current curve 

obtained in 1.4. with that simulated with the Adaptive Grid Simulator. For this purpose we Copy & Paste the 

fixed-grid-simulation by clicking on Simulation -> Copy ( ) and Simulation -> Paste ( ). Note that two 



(identical) current curves are shown now on the screen. The active curve (referring to the active simulation) is 

drawn in black by default while the inactive curve (referring to the inactive simulation) is drawn in green by 

default. (The default colors can be changed as described in 4.2). In order to clarify that really two curves are 

plotted on the screen it may be useful to emphasize the active curve by plotting it in the form of open circles as 

shown in the following picture 

 

The active curve (drawn in black) is the one to which the 

commands in the Simulation-Menu and in the menu Active 

Simulation of the View-Menu refer.  

Consequently, clicking on  

View -> Active Simulation -> Use Circles ( )   

makes that the active curve is plotted in the form of open 

circles  while filled circles are used when clicking on 

View -> Active Simulation -> Use Filled Circles ( )   

 

 

  

 

  

Click on Simulation -> Edit Properties ( ), go to the Simulation Parameters page and enter “0” for Local 

FEM Error. Close the CV-Properties dialog by clicking on OK and click on Simulation -> Run -> Adaptive 

Grid Simulation ( ). After undoing View -> Active Simulation -> Use Circles ( ) one obtains 

 

 

 

 

 

 

 

 

Since Local FEM Error was zero, the FEM-Simulator worked on the same (fixed) 16-points grid as the box 

method in 1.4. Obviously, the active (black) curve referring to the FEM-simulator is not in perfect agreement 

with the inactive (green) curve referring to the box method. (The difference in the peak current amounts to about 

0.5%). In order to get virtually identical curves it is necessary to repeat the Adaptive Grid Simulation using a 

Local FEM Error of about 0.005 as shown in the following picture 

 

 

 

 

 



Because of Local FEM Error > 0 the adaptive grid refinement was enabled now. About 100 additional grid 

points have been introduced in the course of the simulation and the current curve converges exactly to that 

obtained with the box method on the 16-points grid. 

1.6. Adding a chemical reaction 

Now we are going to modify the simple charge-transfer mechanism assuming the reduced species Red would 

undergo a first-order decomposition reaction  (EC-mechanims) 

Click on Simulation -> Edit Properties ( ) and make sure that the Chemical Reactions page is activated. Click 

on the left-most index field associated with the first empty line in Chemical Reaction. The index field will be 

transformed into a combo box offering the options shown in following picture 

 
 

Select Add new Reaction and complete the appearing chemical reaction template in the following way 

 

Syntax:  Species1 + Species2 = Species3 + Species 4 

 

 

Remarks: 

 If the name of a species starts with X, Y or Z it is considered a buffer/excess component. The concentration of such a species does 
not change in the course of the simulation. 

 Excess components or empty strings can be entered only for Species 2 and/or Species 4. 

 (Pseudo-) First-Order reaction: Species 2 and Species 4 are empty strings (or excess components) 

 Second-Order reaction: no species name or only the name of Species 2 or 4 is empty or that of an excess component  

Close the chemical reaction template with OK and enter the following values for the equilibrium constant, Keq, 

and the (forward) rate constant, kf 

 

A large value of Keq (≥10000) was used in order to make the reaction “irreversible”.   

Go to the Simulation Parameters page and enter “CVSim – kf  = 10” as 

simulation name to make it easier to distinguish this simulation from the 

first one referring to the simple charge transfer mechanism. 

Close the CV-Properties dialog by clicking on OK and run the simulation as described in 1.4. The screen display 

should look now as shown in the picture on the left-hand side where “CVSim – kf  = 10” is the active simulation. 

 

 

 

  



That means, the parameters shown when clicking on Simulation -> Edit Properties ( ) refer to the EC-

mechanism. Click on View -> Activate Next Simulation ( ) to activate the simulation referring to the simple 

charge-transfer mechanism as shown above in the picture of the right hand side.  

Now we are going to investigate what happens if the (forward) rate constant, kf, becomes larger and larger. For 

this purpose make sure that “CVSim – kf  = 10” is the active simulation, Copy & Paste this simulation and open 

the the CV-Properties dialog again. (For convenience, these three commands are executed when clicking on 

Simulation -> Duplicate ( )).  Make the following modifications on the Chemical Reactions and Simulation 

Parameters page, respectively: 

Running the simulation gives the results shown in the picture on the left-hand side. 

Repeating the same steps for kf = 1000 and kf = 10000 results in the picture shown on the right-hand side. 

1.7. Editing (modifying) or removing a reaction equation 

Now we are going to investigate under which conditions a second-order follow up reaction becomes (pseudo) 

first-order. Make sure that that “CVSim – kf  = 10000” is the active simulation and click on Simulation -> Copy 

( ) , create a new CV-Simulation Document as described in 1.1. and click twice on Simulation -> Paste ( ) 

to paste two copies of “CVSim – kf  = 10000” into the new simulation document. Then click on Simulation -> 

Edit Properties ( ), go to the Chemical Reactions page and click on the left-most index field associated with 

the first-order reaction 

 

Select Edit Reaction and modify the reaction template as follows 

 

Alternatively, select Remove 

Reaction to remove “Red = P” and 

enter the new reaction  

“Red + A = P + B” 

from scratch as described in 1.6.  



Close with OK and enter the following values for Keq,, kf and the analytical concentrations, Canal (mol/l). 

 

 

 

 
 

 

 

 

 

The values have been selected such as to make kf [A]=10000 where [A] is an abbreviation for the analytical 

concentration of A. A value of 10000 was also used for first-order rate constant in “CVSim – kf = 10000”. Go to 

the Simulation Parameters page and enter “CVSim - kf[A] = 10000, A=0.01” as simulation name. Running the 

simulation reveals that both simulations (the first-order one “CVSim – kf = 10000” and the second-order one 

“CVSim - kf[A] = 10000, A=0.01” ) exhibit identical current curves within an error level smaller than about 

0.5%.  A tenfold excess of species A is therefore enough to obtain pseudo-first order conditions for the selected 

scan rate. However, it is easy to verify that the effect of the second-order reaction can no longer be neglected if 

the ratio of the analytical concentration between Ox and A tends towards 1 or becomes even smaller. For instance 

kf=10
7
 and [A]=0.001 yields the following result (black curve)  

 

 

 

 

 

 

 

 

 

while the green curve refers to the first-order mechanism “CVSim – kf = 10000”. 

 1.8. Deleting a simulation object 

The active simulation can be removed from the (active) simulation document by clicking on Simulation -> 

Delete or on Simulation -> Cut ( ).  In the latter case the simulation is moved to the clipboard and can be re-

pasted again. 

1.9. Adding another chemical reaction  

Remove the simulation object associated with the second-order mechanism by activating 

 “CVSim - kf[A] = 10000, A=0.01” and clicking on Simulation -> Delete . Only “CVSim – kf = 10000” should 



be displayed now on the screen. Then click on Simulation -> Duplicate ( ) and go to the Chemical Reactions 

page. Now we are going to investigate how the current curve changes if Red does not only undergo a first-order 

decomposition reaction but also a catalytic regeneration reaction as expressed in the following equation 

 

This reaction is added by clicking on the left-most index field associated with the first empty line in Chemical 

Reaction 

 

 

 

 

Select Add new Reaction and enter the chemical reaction in the following way 

 

 

 

 

Return with OK and enter the following values for Keq,, kf and the analytical concentrations, Canal (mol/l). 

 

 

 

 

 

 

 

 

Running the simulation (denoted as “CVSim – kf = 10000, cat”) yields the black current curve in the following 

picture:  

 

In this way any number of chemical or charge-
transfer reactions can be added to the 

mechanism.  Note that the lists of reaction 
equations appearing under Chemical Reaction 

and Charge-Transfer Reaction will be 

automatically extended if the last line has been 
filled with a reaction equation. 

 

 

 



2. Retrieving the coordinates of current points, zooming the screen display 

 
2.1. Retrieving the actual position of the mouse cursor 

The actual position of the tip of the mouse cursor is displayed as xy-couple in the status bar  

 

provided View -> Status Bar is check marked. 

 

The coordinates of the current point (of the active simulation!) which is closest to the tip of the mouse cursor are 

displayed on the screen as shown in the picture on the left-hand side when executing a double click with the left 

mouse button.  The command can be repeatedly applied 

 

The coordinates referring to each click are 

displayed using the color settings of Text in Colors  

available on the Preferences 

page. This page is raised by 

clicking on  

View -> Preferences ( )   

 

 

The text can be removed from the display by 

clicking on View -> Refresh ( ). 

 

2.2. Retrieving the coordinates of current peak maxima or minima 

The coordinates of current peak maxima or minima are retrieved by clicking on View -> Active Simulation -> 

Show Min/Max-Info ( ). Then press down the left mouse button and draw a rectangle around the region 

where the minimum/maximum is localized as shown in the picture on the left-hand side. After releasing the left 

mouse button the coordinates of the minimum/maximum (if any) are plotted on the screen as shown in the 

picture on the right-hand side. 

The text can be removed and its default color can be modified as described above in 2.1. 

The command can be repeatedly applied in order to accomplish that the coordinates of all peak currents are 

shown on the screen. Proceed as follows if you want to compare the peak current of the active simulation with 

that of the inactive simulation. After having retrieved the peak current for “CVSim – kf = 10000, cat” as 

described above, click on View -> Activate Next Simulation ( ) in order to accomplish that “CVSim – kf = 

10000” becomes the active CV. This is necessary because the command View -> Active Simulation -> Show 



Min/Max-Info ( ) works only with the current curve of the active simulation. Use this command as described 

above for drawing a rectangle around the region where the peak current of  “CVSim – kf = 10000” is localized 

(see the picture on the left-hand side).  After releasing the left mouse button, the coordinates of both peaks are 

plotted as shown in the picture on the right-hand side. 

 

 

 

 

 

 

 

 

2.3. Zooming and unzooming the screen display 

The screen display can be zoomed by clicking on View -> Zoom ( ), then press down the left mouse button 

and draw a rectangle around the region which is to be zoomed as shown in the picture on the left-hand side. This 

region is expanded to “full screen” as shown in the figure on the right hand side after releasing the right mouse 

button  

The View -> Zoom ( ) – command can be repeatedly applied up to 9 times. The zooming effect can be 

undone by clicking on View -> Unzoom ( ).   

If the original screen display has been zoomed n-times the View -> Unzoom ( )-command must also be 

applied n-times to re-establish the original screen display. 

  



3. Saving the simulation document, saving the screen display, exporting and importing 

simulations 

3.1. Saving the simulation document 
All simulations involved in a simulation document can be saved by means of a standard Windows file dialog that 

appears when clicking on Document -> Save ( ) or Document -> Save As. The first command works “quiet” 

using the default path for saving the simulation document. The second command enables the user to save the 

document with a new name. Document -> Save As is used instead of Document -> Save if a new document (with 

an empty default path) is saved for the first time. 

All chemical parameters and all simulation parameters (including the current curve) but not the settings for the 

screen display such as colors, fonts etc. are saved for each simulation.   
At this point we recommend that the user saves the simulation document obtained so far using the name 

“CVSimSOcat.cvs”. After saving, this name becomes the document’s name shown in the window’s title bar (see 

the previous pictures).   

Note that cvs-files are saved in a binary format which cannot be handled by any third-party software. 

3.2. Saving the screen display 
The graphics of the screen display can be saved in enhanced Windows metafile (emf-) format by clicking on 

Document -> Save Screen Display ( ). The screen display can be saved either in “black and white” or using 

the actual display colors (except the child window’s background color which is always saved in white).  

Whether the first option or the second one is used depends on the default settings of 

Colors in emf-files which can be adjusted by clicking on View -> Preferences ( )   

 

 

 

The default type and size of the font used for labeling the axes in the emf-file can be 

adjusted independently of the screen font by means of a standard Windows font dialog 

that appears when clicking on emf-Files. The Fonts settings are available on the 

Preferences page raised by clicking on View -> Preferences ( )   

The Document -> Save Screen Display-command opens a slightly modified standard Windows file dialog. 

 

 

 

 

 

Clicking on the button Options enables the user 

to select whether the screen display is saved in 

“black and white” or using the actual screen 

colors. This selection applies only to the actual 

operation and does not overwrite the default 

settings of Colors in emf-files on the Preferences 

page. 

 

 

 

 

 



source program: DigiElch for Windows  

program version: 3.0 

file type: CV 

 

experimental parameters: 

Pre-Equilibrium: smart 

Diffusion: Semi-Infinite 1D 

Geometry: Spherical (Hg) 

Mass (mg): 4 

Ru (Ohm): 0 

Cdl (F): 0 

Temp. (K): 298.2 

Potential steps (V): 0.005 

Estart (V):0 

Segment: 1 

Eend (V): -1 

v (V/s): 10 

Segment: 2 

Eend (V): 0 

v (V/s): 10 

species parameters: 

[Ox] (M/l): 0.001 

[Red] (M/l): 0 

[P] (M/l): 0 

[H+] (M/l): 0.01 

[H] (M/l): 0 

experimental CV-data: 

number of E (V), I (A) couples: 400 

-0.005 , 2.8397268E-011 

-0.01 , 3.4379793E-011 

-0.015 , 4.1844406E-011 

: 

-0.025 , 6.1705094E-011 

-0.03 , 7.4954974E-011 

3.3. Exporting a simulation 

The current curve of the active simulation can be exported in ASCII- format by applying the Simulation -> 

Export ( ) – command. It opens a slightly modified standard Windows file dialog   

 

 

 

 

 

The two different export options are described in the 

following: 

 

3.3.1. Export Option: Use Format (*.use) 

Pressing directly the Export button saves the current curve, the  Experimental Parameters (i.e. the parameters for 

Scan, Pre-Equlibrium, Geometry, Diffusion and Experimental Conditions) as well as the Species Parameters 

(Species concentrations and boundary conditions) shown on the CV-Properties dialog (but not the Chemical 

Reactions and Preferences) in an ASCII format that can be re-imported into DigiElch. Note that the key words 

are identical with the parameter names on the Simulation Parameters page shown of the CV-Properties dialog 

raised by clicking on Simulation -> Edit Properties ( ). 

Thus, for instances, when exporting the simulation “CVSim – kf = 10000, cat” (contained in the simulation 

document that has been saved as “CVSimSOcat.cvs” in 2.1.) the following data are written to the use-file (the 

left-hand side shows the data actually written to the use-file, the right-hand-side the general structure of the use-

format) 

DigiElch CV-Header 
“program version” means here the version of the use-format  

which is “3.0” and may be different from the version of DigiElch. 
 
experimental parameters: 

key_word_1: Value_1 

key_word_2: Value_2 

: 
: 

etc. 

 

 

 

 
 

 

species parameters: 

[name of species_1] (M/l): Canal_1 
[name of species_2] (M/l): Canal_2 

. 

. 
 

 

 

experimental CV-data: 
number of E(V), I (A) couples: N 

E_1 ,  I_1 
E_2 ,  I_2 

etc. 



source program: DigiElch for Windows 

program version: 3.0 

file type: CV 

 

experimental parameters: 

Pre-Equilibrium: smart 

Diffusion: Semi-Infinite 1D 

Geometry: Spherical (Hg) 

Mass (mg): 4.1 

Ru (Ohm): 0 

Potential steps (V): 0.005 

Estart (V):0 

Segment: 1 

Eend (V): -1 

v (V/s): 10 

Segment: 2 

Eend (V): 0 

v (V/s): 10 

: 

: 

 

 

 

 

Experimental and Species Parameters can be modified or excluded from being exported using the dialog box that 

appears when pressing the Options button: 

 
Note the difference between an empty input field 

and an input field where "0" has been entered. In 
the example shown left no entry is produced in 

the use-file for the double layer capacity, Cdl (F), 

and for the temperature, Temp.(K),  while Ru 
(Ohm) = 0 is explicitly written to the file.  

 

In the above example, a mercury mass of 4.1mg is written to the use-file while the current curve contained in this 

file refers to 4.0mg. Why does DigiElch provide an option for falsifying parameter values before exporting 

them? The answer is quite simple: use-files are mainly intended for fitting purposes. In such a situation it makes 

thoroughly sense to investigate the effect of a systematic parameter error on the thermodynamic and or kinetic 

constants retrieved by the fitting routine. In other words, falsified use-files could be used to mimic experimental 

data files where some experimental parameters such as electrode size or species concentrations are not exactly 

known. Subjecting such files to data fitting provides an easy way to investigate how an uncertainty in some 

experimental parameters is passed to the thermodynamic and or kinetic constants we are interested in. 

 

3.3.2. Export Option: E-I-couples (*.txt) 

Data exported in this way cannot be re-imported into DigiElch. The purpose of this export option is to export the 

current curve in a format that can be easily handled by third-party presentation software. For this purpose a few 

formatting options are provided.  

By default (i.e. when selecting this export filter and pressing directly the Export button in 

the Windows file dialog box shown in 3.3.) the current curve is exported in the form of 

voltage-current couples using the number-format and the separator selected in Exporting 

Data available on the Preferences page which is raised by clicking on  

View -> Preferences ( ) .  
This selection can be temporarily overwritten (without changing the default settings in 

Exporting Data) by clicking on the Options button in the Windows file dialog box shown 

in 3.3.   

 

  



source program: DigiElch for Windows 

program version: 3.0 

file type: CV 

 

experimental CV-data: 

number of E (V), I (A) couples: 400 

-0.005 , 2.8397268E-011 

-0.01 , 3.4379793E-011 

-0.015 , 4.1844406E-011 

: 

: 

 

 

 

 

3.4. Importing simulated or experimental CVs 

Two import commands are available. The first one (Simulation -> Import (*.use) ( )) can be used for 

importing CV-simulations or experimental CVs stored in use-format (see 3.3.1.). The second one (Simulation -> 

Import (*.txt, *.dat) ) can be used for importing experimental CVs produced by a few third party instruments 

supported by DigiElch. Both import commands raise a slightly modified Windows file dialog box: 

 

The available import filters depend on the actual version of 

the DigiElchImport.dll.   

When the Merge Files button is check marked, the imported 

CV-objects are merged (added) to those already present in 

the active simulation document.  When de-activated, all 

simulations in the active simulation documents are deleted 

before importing the file(s).       

Clicking the Options button enables the user to decide 

whether the sign of the cathodic/anodic current is changed 

by multiplying the current values with -1. This is necessary 

only when importing files where the sign convention used in 

the file is different from that expected by DigiElch. (In 

DigiElch, the cathodic current is assumed to be positive).  

Do not use this option for importing standard use-files 

produced by DigiElch!!  

 

3.4.1. Importing data files in use-format  

When importing use-files (see 3.3.1), the Experimental and Species Parameters of the active simulation serve as 

default values for the imported object. These values are overwritten only if an entry for this parameter is 

explicitly found in the use-file.  

The minimum use-format accepted by DigiElch (shown on the left-hand side) requires 

the  

DigiElch CV-Header   

 

followed by the following two lines: 

 

experimental CV-data: 

number of E(V), I (A) couples: N 

 

where N is the number of voltage-current couples representing the current curve. The 

numbers must be in point format and separated by a comma. 

When re-importing a file in minimum use-format (containing only the current curve), the Experimental and 

Species Parameters for the imported object are exclusively taken from the active simulation. The main purpose 

of the minimum use-format is to offer an easy and straightforward way for importing data produced by third-

party instruments into DigiElch. It is up to the user to ensure (by entering appropriate values for the active 

simulation) that these parameters are in a reasonable relationship to the imported current curve. 

3.4.2. Importing ASCII-files from third-party instruments supported by DigiElch 

Most of the import filters provided for this purpose extract only the experimental current curve from the txt- or 

dat-file.  As in the case of importing files in minimum use-format the Experimental and Species Parameters for 

the imported object are exclusively taken from the active simulation and it is up to the user to ensure (by entering 

appropriate values for the active simulation) that these parameters are in a reasonable relationship to the 

imported current curve. 

4. Customizing colors, fonts and the drawing of the cyclic voltammatric current curve 
The options for customizing colors, fonts and the drawing of the screen display are split into two groups: The 

first group involves options which apply to all windows associated with a CV-simulation document no matter 

whether CV-current curves, concentration profiles ore fitting objects are displayed.  The second group applies 

only to the display of the cyclic voltammetric current curves.  



4.1. Customizing options applying to all windows 

These options are compiled on the Preferences page which appears by clicking on View -> Preferences ( ).  

 

 

The options for Colors in emf-files have already been described in 2.2. The remaining options work as follows: 

Fonts 

The default font and its size used for labeling the axes can be adjusted independently for screen display, printing 

and for the saving of the screen graphics in emf-format by means of the standard Windows font dialog that 

appears when clicking on the associated text field.  

Colors 

The default colors for drawing the info-text, for labeling axes as well as the child-window’s background color 

and the color of dialog boxes can be adjusted by means of the standard Windows color dialog box that appears 

when clicking on the associated color field. The color shown in the field associated with Dialog boxes is only 

used if use standard dialog colors has not been selected. Otherwise, the color settings of the operating system are 

used for all DigiElch’s dialog boxes. Note that changing the color settings for Dialog boxes and Child window 

takes effect only when creating/opening a new dialog box/child window. 

Drawing 
This selection decides whether a normal or a thick pen is used for printing, storing emf-files and drawing the 

screen display. 

Example: 

left-hand side: appearance of the screen display using the Fonts-, Colors- and Drawing-settings shown above 

right-hand side: appearance of the screen display using the Fonts-, Colors- and Drawing-settings shown below 

 

 

 

 

 

Resetting the default colors: 

The default colors can be reset by clicking on View -> Reset Default Colors in DigiElch’s start menu. The latter 

is active only immediately after starting DigiElch or when closing all child windows. 



4.2. Customizing options applying only to the display of the cyclic voltammetric current curves 

Clicking with the right mouse button while the mouse cursor is localized over the window showing the CV-

current curve opens the dialog box shown on the right-hand side. The screen display produced with these 

Options, Labels and Colors is shown in the picture on the left-hand side: 

 

 

 

 

 

 

 

Options 

 Classical/IUPAC 

if Classical is selected negative potentials are drawn from left to right and the cathotic current is 

positive. Otherwise positive potentials are drawn from left to right and the cathotic current is negative 

 Total current/Current density 

Either the total current or the current density is plotted. 

 Show all simulations/Show active simulation 

Either the current curves of all simulations involved in the simulation document or only that of the 

active simulation is plotted. 

Colors  

The default colors for drawing the background, the active CV, the inactive CV and the inactive cycles 

(segments) of the active CV can be adjusted by means of the standard Windows color dialog box that appears 

when clicking on the associated color field.  

Labels 
The default labeling for the x- and y-axis can be modified by changing the text in the associated text field. Note, 

however, that the label “I (A/cm²)” is always used if Current density is selected. 

The effect of the settings in Options, Labels and Colors can be summarized by comparing the screen display 

referring to the following settings with that shown above  

 

 

 


